Indicare le celle di Excel.

Mauro Goretti & Aramini Parri Lucia

Indicare le celle di Excel.
Per potere reperire informazioni presenti in file e fogli di lavoro differenti bisogna innanzitutto sapere che Excel gestisce i riferimenti alle celle.
Per indicare una cella specifica si deve scrivere:

{Nome/Documento}Nome\Foglio\cella

Per un gruppo di celle invece è:

{Nome/Documento} NomeFoglio!CellaIniziale:CellaFinale

Un esempio; la formula sottostante esegue la somma delle celle C2:C20 del foglio Clienti contenuto nel file Fatture.xls

=SOMMA([Fatture.xls]Clienti!C2:C20)

Un'alternativa che presenta un'importante differenza, è questa:

=SOMMA(Fattura.xls]Clienti!$C$2:$C$20)

Avrete notato la presenza dei simboli del dollaro ($) nell'indicazione del range di celle. Ci chieseremo che differenza ci può essere tra le due forme? I riferimenti senza il simbolo del dollaro ($) sono detti Assoluti e puntano sempre alle stesse celle anche quando la formula viene copiata o spostata in un altra posizione. Gli altri invece sono Relativi e vengono aggiornati automaticamente da Excel. Spostando ad esempio un cella con la formula: =SOMMA($C$2:$C$20) dalla posizione A1 a A2 i riferimenti rimarrebbero invariati, mentre effettuando la stessa operazione con:
=SOMMA(C2:C20) si otterrebbe: =SOMMA(C3:C21).

Post popolari in questo blog

Gli Scozzesi,usanze,costumi e tradizioni.

Com'è fatta un'automobile.

L'igiene dell'apparato scheletrico. Anatomia.